Register a SA Forums Account here!
JOINING THE SA FORUMS WILL REMOVE THIS BIG AD, THE ANNOYING UNDERLINED ADS, AND STUPID INTERSTITIAL ADS!!!

You can: log in, read the tech support FAQ, or request your lost password. This dumb message (and those ads) will appear on every screen until you register! Get rid of this crap by registering your own SA Forums Account and joining roughly 150,000 Goons, for the one-time price of $9.95! We charge money because it costs us money per month for bills, and since we don't believe in showing ads to our users, we try to make the money back through forum registrations.
 
  • Post
  • Reply
SamDabbers
May 26, 2003



I'm having some trouble with a remote access VPN using the Cisco VPN Client to a 3825. When I attempt to connect, the VPN client spits out this in the logs:

code:
Cisco Systems VPN Client Version 5.0.03.0530
Copyright (C) 1998-2007 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Windows, WinNT
Running on: 5.1.2600 Service Pack 3
Config file directory: C:\Program Files\Cisco Systems\VPN Client\

1      19:31:35.957  09/09/08  Sev=Warning/3	IKE/0xE3000057
The received HASH payload cannot be verified

2      19:31:35.957  09/09/08  Sev=Warning/2	IKE/0xE300007E
Hash verification failed... may be configured with invalid group password.

3      19:31:35.957  09/09/08  Sev=Warning/2	IKE/0xE300009B
Failed to authenticate peer (Navigator:904)

4      19:31:35.957  09/09/08  Sev=Warning/2	IKE/0xE30000A7
Unexpected SW error occurred while processing Aggressive Mode negotiator:(Navigator:2238)
Now, it looks like the group name and/or password is incorrect, but I've reentered them both by hand and copy/paste on both the client and the router multiple times. There are no spaces or punctuation in either name, just upper case, lower case, and numbers. I've even tried removing ALL the VPN configuration from the router, putting it back in again, and creating a new .pcf on the client side.

Nothing seems to work! I'd appreciate any ideas you guys might have. Here's the router configuration:

code:
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname bwsrouter
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa group server radius BWSOD
 server-private 10.168.1.4 auth-port 1812 acct-port 1813 key bws123456
!
aaa authentication login BWS_VPN_users group BWSOD local
aaa authorization network BWS_VPN_auth group BWSOD local 
!
aaa session-id common
!
resource policy
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
ip cef
ip tcp selective-ack
ip tcp timestamp
!
!
ip inspect name firewall-out tcp
ip inspect name firewall-out udp
ip inspect name firewall-out cuseeme
ip inspect name firewall-out h323
ip inspect name firewall-out rcmd
ip inspect name firewall-out realaudio
ip inspect name firewall-out streamworks
ip inspect name firewall-out vdolive
ip inspect name firewall-out sqlnet
ip inspect name firewall-out tftp
ip inspect name firewall-out ftp
ip inspect name firewall-out icmp
ip inspect name firewall-out sip
ip inspect name firewall-out fragment maximum 256 timeout 1
ip inspect name firewall-out netshow
ip inspect name firewall-out rtsp
ip inspect name firewall-out pptp
ip inspect name firewall-out skinny
no ip dhcp use vrf connected
ip dhcp excluded-address 10.168.1.1 10.168.1.49
!         
ip dhcp pool inside-pool
   network 10.168.1.0 255.255.255.0
   default-router 10.168.1.1 
   dns-server 10.168.1.4 
   domain-name my.domain
   netbios-node-type b-node
!         
!         
no ip bootp server
no ip domain lookup
ip domain name my.domain
ip ssh version 2
!         
!         
!         
crypto pki trustpoint TP-self-signed-3557539967
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3557539967
 revocation-check none
 rsakeypair TP-self-signed-3557539967
!         
!         
crypto pki certificate chain TP-self-signed-3557539967
 certificate self-signed 01
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH BLAHBLAH
  quit    
username admin privilege 15 secret 5 toomanysecrets
!         
!         
!         
crypto isakmp policy 10
 encr 3des
 hash md5 
 authentication pre-share
 group 2  
!         
crypto isakmp client configuration group bwsvpn
 key cisco123
 dns 10.168.1.4
 domain my.domain
 pool vpnpool
 acl bwsvpnacl
 pfs      
!         
!         
crypto ipsec transform-set ESP-AES-256-SHA esp-aes 256 esp-sha-hmac 
!         
crypto dynamic-map outside_dyn_map 1
 set transform-set ESP-AES-256-SHA 
 reverse-route
!         
!         
crypto map outside_map client authentication list BWS_VPN_users
crypto map outside_map isakmp authorization list BWS_VPN_auth
crypto map outside_map client configuration address respond
crypto map outside_map 1 ipsec-isakmp dynamic outside_dyn_map 
!         
!         
!         
interface GigabitEthernet0/0
 description Internal LAN
 ip address 10.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!         
interface GigabitEthernet0/1
 description Internet
 ip address x.x.x.y 255.255.255.248
 ip access-group outside_in in
 no ip redirects
 no ip unreachables
 ip inspect firewall-out out
 ip nat outside
 ip virtual-reassembly
 no ip mroute-cache
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 no cdp enable
 crypto map outside_map
!         
ip local pool vpnpool 10.168.2.1 10.168.2.30
ip classless
ip route 0.0.0.0 0.0.0.0 69.15.195.169
!         
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list NAT_out interface GigabitEthernet0/1 overload
ip nat inside source static 10.168.1.4 x.x.x.x route-map NAT-out-static
!         
ip access-list standard RemoteAdmin
 permit 10.168.1.0 0.0.0.255
!         
ip access-list extended NAT_out
 deny   ip host 10.168.1.4 any
 deny   ip 10.168.1.0 0.0.0.255 10.168.2.0 0.0.0.255
 permit ip 10.168.1.0 0.0.0.255 any
ip access-list extended NAT_out_static
 deny   ip 10.168.1.0 0.0.0.255 10.168.2.0 0.0.0.255
 permit ip 10.168.1.0 0.0.0.255 any
ip access-list extended bwsvpnacl
 permit ip 10.168.1.0 0.0.0.255 10.168.2.0 0.0.0.255
ip access-list extended outside_in
 permit tcp any host x.x.x.x eq www
 permit tcp any host x.x.x.x eq 443
 permit tcp any host x.x.x.x eq 993
 permit tcp any host x.x.x.x eq 995
 permit tcp any host x.x.x.x eq pop3
 permit tcp any host x.x.x.x eq 465
 permit tcp any host x.x.x.x eq 587
 permit tcp any host x.x.x.x eq smtp
 permit tcp any host x.x.x.x eq 143
 permit icmp any any echo
 permit icmp any any echo-reply
 permit icmp any any time-exceeded
 permit tcp any host x.x.x.x eq 1723
 permit tcp any host x.x.x.y eq 22
 permit gre any host x.x.x.x
 permit udp any any eq isakmp
 permit udp any any eq non500-isakmp
 permit esp any any
 permit udp any host x.x.x.x eq ntp
!         
route-map NAT-out-static permit 10
 match ip address NAT_out_static
!         
!         
!         
control-plane
!         
!         
!         
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 access-class RemoteAdmin in
 privilege level 15
 transport input ssh
line vty 5 15
 access-class RemoteAdmin in
 privilege level 15
 transport input ssh
!         
scheduler allocate 20000 1000
ntp clock-period 17179867
ntp server 130.126.24.24
ntp server 129.6.15.29
ntp server 130.126.24.44
!         
end

Adbot
ADBOT LOVES YOU

SamDabbers
May 26, 2003



Syano posted:

Trying to figure out a way to integrate the device with least amount of effort. I want the 5510 to become the new default gateway for this network and it sure would be easy to tag on an additional address to eth0 instead of changing default gateways on tons of statically configured devices

Keep in mind that an ASA is not a router; it's a security device. It'd be much easier to stick a layer 3 switch or a basic router with two FastEthernet ports in between it and your network like Girdle Wax posted above.

Sub-interfaces are really only useful if you have multiple VLANs that need to connect up to the ASA.

SamDabbers
May 26, 2003



riske posted:

I'm having some trouble with a remote access VPN using the Cisco VPN Client to a 3825. When I attempt to connect, the VPN client spits out this in the logs:

*SNIP*

Now, it looks like the group name and/or password is incorrect, but I've reentered them both by hand and copy/paste on both the client and the router multiple times. There are no spaces or punctuation in either name, just upper case, lower case, and numbers. I've even tried removing ALL the VPN configuration from the router, putting it back in again, and creating a new .pcf on the client side.

Nothing seems to work! I'd appreciate any ideas you guys might have. Here's the router configuration:

*SNIP*

I figured this out in case anyone was wondering. My RADIUS server wasn't handing out authorization information properly. When I changed this line:
code:
aaa authorization network bwsvpn_users group BWSOD local
to only use the local authorization database:
code:
aaa authorization network bwsvpn_users local
it started working fine!

SamDabbers
May 26, 2003



Erwin posted:

I have a question about NAT traversal for SIP (I think). We switched to a new VOIP provider for our 20+ VOIP phones. They recommended an 1841 router for our largest location with 17 phones. Now we're having a problem with a few phones randomly not registering to their SIP server, and from what I can tell, it's because the 1841 doesn't translate SIP packets when NATing. The VOIP provider's response is to use our Juniper SSG140 for NATing, turning the 1841 into a fancy T1 interface, and something I'd like to avoid.

Is there no way to get the 1841 to play nice with SIP? I'm really annoyed that the provider's 'best practice' suggestion turns out to not be SIP-aware (at the time, I was not SIP-aware-aware and didn't realize that I should look out for such a thing).

Try something like this: (assuming FastEthernet1 is your "inside" interface)

code:
ip inspect name firewall tcp
ip inspect name firewall udp
ip inspect name firewall sip
ip inspect name firewall rtsp
ip inspect name firewall rtp
interface FastEthernet1
ip inspect firewall in

SamDabbers
May 26, 2003



That should be possible if you're on the same layer 2 segment, at least in theory.

SamDabbers
May 26, 2003



tortilla_chip posted:

http://en.wikipedia.org/wiki/Digital_Signal_1

Does wikipedia count :)

From the "bandwidth" section:

Wikipedia posted:

A DS1 is also a full-duplex circuit, which means the circuit transmits and receives 1.544 Mbit/s concurrently.

Here's another source:

NetworkDictionary.com posted:

Within the communications network, copper twisted pairs are used. One pair for transmit, and another for receive making four wires for each T1. This allows T-carrier systems to transmit and receive simultaneously in both directions at full speed (full duplex).

SamDabbers
May 26, 2003



analogsoul posted:

MTU 1500 bytes, BW 100 Kbit, DLY 100 usec,

This might be your problem.

SamDabbers
May 26, 2003



Cizzo posted:

Why does the following IPv6 address have a prefix of 60?
2001:0:0:AB0::/60

Why is it not 64?

It's a larger allocation that you can split into 16 (2^4) /64s.

SamDabbers
May 26, 2003



Is the switch port this router plugs into also configured for 100/full? It might be trying to negotiate speed and duplex.

SamDabbers
May 26, 2003



Having lots (hundreds) of hosts on a single subnet produces excessive broadcast traffic, which has to be propagated to every single machine on that VLAN. If your VLAN spans several buildings...think about it.

A school I worked with had a similar setup; 3 buildings on one big VLAN (10.0.0.0/8), with 100Mbps wireless links between the buildings. Each building had a separate Internet connection and firewall, and they directed traffic by setting the appropriate default gateway.

That network CRAWLED. They couldn't even get full speed out of a 20Mbps cable modem at any given site. Luckily, the sole IT guy had the foresight to number all the machines at each site with the same second octet (e.g. 10.5.0.0, 10.6.0.0, etc) so it was fairly simple to expand the subnet mask to a /16 for each building and make the firewalls route inter-building traffic. Network performance dramatically improved, especially for inter-building transfers.

Word to the wise: bring in an expert to reorganize your network. You shouldn't need to pay for public addresses for machines that aren't running a public service, and judicious use of subnetting, routing, and even NAT will likely improve both performance and reliability, and make it easier to troubleshoot when something goes sideways.

SamDabbers
May 26, 2003



Zuhzuhzombie!! posted:

So if the process ID has nothing to do with DR election, nothing to do with the router ID, and is only significant to the router it's on and can be duplicated on other routers, then what does it do exactly? What is it significant to?

It is possible to have a router be a part of multiple separate OSPF networks. The process ID is simply a way to distinguish between them within the router's config.

SamDabbers
May 26, 2003



Zuhzuhzombie!! posted:

So if a router is a member of multiple Areas it will use the process ID to manage that area membership/database/etc?

No, the process ID indicates two completely separate OSPF clouds. Think VRFs. For example, ports Gig0/1 & Gig0/2 could be assigned to OSPF process 1 and exchange one set of LSAs with neighbors, and ports Gig0/3 & Gig0/4 could be on OSPF process 2 and have a completely separate set of LSAs to exchange with neighbors on those ports. Both OSPF processes can be assigned to the backbone area, but it would be two completely separate backbone areas.

SamDabbers
May 26, 2003



Zuhzuhzombie!! posted:

Sorry, but I'm still confused! So... would it be more like running multiple instances of EIGPR via multiple AS numbers?

Not really. Each EIGRP instance is analogous to an OSPF area. Read up on VRF for a use-case where you'd run multiple OSPF processes, or VRF-Lite if you don't want to get too deep into MPLS. The gist is that you can have multiple discrete routing tables coexisting in a single router, and each OSPF instance operates on a single routing table.

Say that you're running a service provider backbone network, and you have a client who wants a Layer 3 (routed) VPN between their multiple sites. They run OSPF internally and use 10.0.0.0/8. You already run OSPF on your routers, and also use 10.0.0.0/8, so you don't want your routes distributed into the client's network or vice-versa. The solution is to assign the client-facing interfaces to a VRF (separate routing table) and set up a second OSPF process on your routers to peer with their routers and use the client VRF. That way, their routing table is propagated between their sites over your network, while your routing table remains isolated from theirs.

SamDabbers fucked around with this message at 22:08 on Apr 22, 2013

SamDabbers
May 26, 2003



Sepist posted:

Does anyone know of any good way to calculate bandwidth requirements for many online services? There is no baseline we can go by, company would start off with 20k OWA users, thousands of servers/workstations utilizing backup over the WAN, CRM, Webhosting and BES. I'm guestimating 3Gb based on past experience but I don't think I can present it that way.

Maybe you could recommend going with a Metro Ethernet provider who can do a 10Gbps loop and instant-scalable bandwidth. Then you can start at, say, 2Gbps and turn it up if that turns out to be insufficient.

SamDabbers
May 26, 2003



Bluecobra posted:

I'm almost tempted to setup a FreeBSD server with top shelf Xeons and a high-performance 10GbE NIC like a Solarflare 6122 to see what performance I can get from pf.

IIRC, pf is still single-threaded, though there's someone working on a patch to make it multithreaded. That's not to say it performs poorly, but I'd go for more GHz over more cores when choosing a CPU.

SamDabbers
May 26, 2003



ToG posted:

Can you explain this to me like I'm five? What's arista?

Arista makes some really killer switches. The 'show donkeys' command appears to be an easter egg.

SamDabbers
May 26, 2003



ruro posted:

Serious reply: Ubiquiti Edgerouter - http://www.ubnt.com/edgemax! Has a pretty UI.

These are definitely nice for the $99 pricetag. They'll even do OpenVPN for remote access, but you'll have to configure it via CLI since the Web UI doesn't have that part implemented yet. It's basically Vyatta under the hood, so just about anything you can do with Vyatta, you can do with the Edgemax.

SamDabbers
May 26, 2003



QPZIL posted:

"IPv6 is the way of the future!"

Join us in the futurepresent! Get a tunnel and experience the IPv6 Internet for yourself! Also, "IPv6 Evangelist" is a real job, apparently.

SamDabbers
May 26, 2003



Why would it be better to cap it at 64 or 48 bits instead of 128? The whole point was to make it such a large address space that we'd never have to deal with the address exhaustion problem again, at least on this planet. Also, it allows for some cool features like mapping a 48-bit MAC address into the 64-bit host portion for auto-addressing within a subnet. You couldn't do that as easily with a 64 or 48 bit address.

SamDabbers
May 26, 2003



moron posted:

... hooked into my DSL modem. I was kinda looking for something with decent gigabit performance though ...

Do you really need a GigE interface for a DSL connection? That 1841 you have should rock anything through ADSL2+ speeds, and FastE would not be a bottleneck.

SamDabbers
May 26, 2003



ruro posted:

I can't see SLAAC being terribly important on an enterprise network that uses DHCP. Particularly DHCP can be used to deliver non-addressing related options (NTP, TFTP, etc).

You can use DHCPv6 to deliver the non-addressing related options AND use SLAAC. It doesn't have to be stateful DHCPv6.

SamDabbers
May 26, 2003



adorai posted:

Is there a curmudgeons guide to ipv6 available somewhere on the internet? I'm a real IT person with real networking knowledge, but have done nothing with ipv6. I feel like I am way behind the times since I'm not even running it at home.

Get a free tunnel and check out the tests/exercises here.

SamDabbers
May 26, 2003



ARIN will give you a /44 if you tell them you have two sites. It's great that the address space is so large because it's really easy to get roomy allocations.

SamDabbers
May 26, 2003



FatCow posted:

I could get a /32 if I wanted to be a dick.

That's the thing...the address space is so massive that the dickliness of taking up a /32 would be miniscule. Here's an illustration of just how big we're talking.

SamDabbers
May 26, 2003



sellouts posted:

This is more of a Cisco hardware question vs a software question.

I'm moving into an office with a 500X switch with a fiber run connecting the other half of the office to another 500X switch. I have to replace one of these switches but not the other.

Could I save some money and get a 500 series switch with a 5gb SFP fiber module to connect to the 500x with 10gb SFP?

Can you not just reuse the SFP from the switch you're replacing? Why are you replacing it to begin with?

SamDabbers
May 26, 2003



Protokoll posted:

Each customer is going to be getting a port with a public address and it's their responsibility to protect their traffic.

Why even bother with trying to isolate the traffic between customers? Set up DHCP snooping/ARP inspection to mitigate IP spoofing, put it all in a big layer 2 (to save addresses and complexity) and call it a day. This also saves you from having to devise a way for NOC personnel to permit desired customer-to-customer traffic later.

Alternatively, what about PPPoE? Bump up the L2 MTU a little so the path is 1500 byte clean, ACL deny anything but PPPoE on the access ports, and all traffic goes through the router so you can filter to your heart's content. You can even pass ACL rules via RADIUS.

SamDabbers
May 26, 2003



What FHRP are you running on the firewalls? RFC-compliant VRRP should use a consistent MAC for the gateway IP to avoid this ARP caching issue entirely.

SamDabbers
May 26, 2003



psydude posted:

I'm currently on a network that is using public IP addresses for internal addressing. :lol:

What, you want to use NAT?

jwh posted:

I think it's ironic (tragic?) that I don't even have any IGPs running anymore. Especially considering all the work I had done with them formerly.

No IGPs and no RFC1918...is this the future?

SamDabbers
May 26, 2003



You could sign up for an "eval account" if you'd rather not talk to your rep for some reason. The link is on the right of this page:

http://www.juniper.net/support/downloads/?p=junosvfirefly-eval#sw

SamDabbers
May 26, 2003



Marvel posted:

This isn't really Cisco-specific but I do have a networking question.

My company is moving offices and I'm wiring it up for the first time but I don't really know what I'm doing.

I need at least 4 ports of 802.3t PoE for the 4 ubiquiti 802.11ac access points plus a shitload more normal PoE ports for phones. I think I'm getting a Netgear GS728TP-100NAS switch, plus a bigass
CyberPower OL1500RTXL2U UPS (power is poo poo here and this will power a couple mac mini servers, router, modem, etc)

Plus a Tripp-Lite floor-standing rack and a patch panel. Does that sound OK?

Seems like a decent setup. Are you doing the cabling for the drops too, or is a cabling contractor taking care of that?

Marvel posted:

What do you do for all the super short cables you need to hook everything up? Seems overkill to make all those cables by hand?

Edit: Derp, looks like you can buy a pack of 1ft patch cables.

Buy all your cables from Monoprice.

SamDabbers
May 26, 2003



Marvel posted:

My friend and I already muddled through the cabling this weekend. It only cost me 4 hours and a pizza so if I screwed something up I can redo it. I'm thinking of using a little PC Engines WRAP board running pfSense for the router (already on-hand). My upstream connection is pretty terrible so it won't be pushing too many packets. It apparently can do the QoS for the phones.

Unless your office is stuck on <10Mbit DSL, that WRAP board is likely not powerful enough. You're already using UniFi APs, and an EdgeRouter Lite will blow the WRAP board out of the water for about $100.

SamDabbers
May 26, 2003



Begby posted:

Not flat, we do have a vlan for phones. We recently changed the subnet of the network from /24 to /23 and change the voice subnet.

We have multiple switches, with a router off the core switch and the ASA off the core switch. Everyone points to the router as the default gateway, and the router has the ASA as it's 0 0 destination.

We haven't rebooted the router since the changes, we are going to try that soon.

The router may be sending ICMP Redirects if ASA, router, and hosts are on the same subnet. This will cause an entry to be made in the routing table of each host for each non-subnet-local address they try to reach. Maybe you could set no ip redirects on the router's LAN interface? You could probably also solve your ARP problem by putting your ASA on a dedicated (sub)interface on the router, instead of on the same subnet as the hosts.

SamDabbers fucked around with this message at 18:35 on Mar 5, 2014

SamDabbers
May 26, 2003



ZergFluid posted:

Can you use telnet/ssh to access a remote router or switch, and then use Cisco Discovery Protocol on the router/switch you're logged into to discover their neighbors?

Assuming the neighbor devices speak CDP and have it enabled on the interface(s) connected to the device you're ssh'd into.

sh cdp neigh

SamDabbers
May 26, 2003



Multichassis LACP seems to be what you're looking for.

SamDabbers
May 26, 2003



Cenodoxus posted:

I was also considering an Ubiquiti EdgeRouter Lite, but I've heard mixed reviews and I can't get a solid answer on how well it supports/implements 802.1p.

The EdgeRouter's hardware acceleration doesn't work if you enable QoS, but is that actually important for a 1Gbps connection? Stateful firewall, NAT, VLAN tags, and IPsec can all be offloaded for both IPv4 and IPv6. The beta firmware has support for PPPoE offload too, in case it's applicable to Google Fiber.

SamDabbers
May 26, 2003



Cenodoxus posted:

Hmm, good to know. In this case, yes, it's important, but only for upload speeds. Here's the situation -

All traffic to and from the ONT is on VLAN 2. Their headend expects upstream frames to be CoS-tagged or else your upload gets throttled to 10Mbps. I believe the recommendation is that DHCP is priority 2, IGMP is 6, and all other traffic is 3. Basically, you can set everything to 3 and forget the rest.

Downstream is not class-tagged.

Others have reported being able to stick a small managed switch between the ONT and the router to handle stuff like the VLAN and CoS tagging, but I'd like to see if it's possible to cut out the middleman.

Given these requirements, I'd go with an EdgeRouter Lite for bang-for-the-buck routing and a Netgear GS108T switch for VLAN/CoS tagging. It's probably the least expensive option (under $200) that can push several hundred kpps. I have both of these devices and tested the configuration successfully. The switch can assign an arbitrary priority tag to all packets coming in on an untagged interface and propagate it out a tagged port.

Here are some screencaps. Interface g1 is connected to a desktop and configured to be untagged on VLAN 1; interface g3 is connected to a machine running Wireshark and is configured to receive tagged frames. The second screenshot shows the 802.1q header received on g3 before I set g1 to have a priority tag (it shows 0), and the third screenshot shows priority tag 3 applied.

SamDabbers
May 26, 2003



Most installations I've seen use 568B.

SamDabbers
May 26, 2003



Powercrazy posted:

Any good resources for IPv6?

If you're the learn-by-doing type, Hurricane Electric's tunnelbroker.net and "certification program" provide both connectivity and a set of tasks to complete (e.g. set up an IPv6-enabled email server, IPv6 DNS glue), and they'll give you a free t-shirt if you do all the tasks.

Also, this presentation covers most of the basics, and this one covers subnetting.

SamDabbers fucked around with this message at 18:02 on Apr 30, 2014

SamDabbers
May 26, 2003



Zero VGS posted:

I was reading that about different subnets being required for Anyconnect and the LAN. There's no way around that? Because Steam "requires" the PCs to be found on the same subnet.

This is an explaination of the steam in-home streaming discovery protocol: http://codingrange.com/blog/steam-in-home-streaming-discovery-protocol

That makes it sound like if I could forward all the UDP/TCP ports across subnets it might work.

Steam IHS uses IPv4 broadcast for discovery, so forwarding the ports between distinct subnets probably won't work. It seems like you'd need to bridge the VPN client onto the LAN, and I'm not sure if it's even possible to do bridging on an ASA. It is possible to have your VPN pool be a subset of the LAN subnet and use proxy arp, but that probably doesn't forward broadcast packets.

I'd try setting up OpenVPN with a bridged TAP interface.

Even if you can get the streaming to work via VPN, it probably won't work very well, but it's fun to try.

Adbot
ADBOT LOVES YOU

SamDabbers
May 26, 2003



Zero VGS posted:

OK, I'll research the OpenVPN bridged tap thingy.

Would it change anything if I had two ASAs? Could I set them up for a site-to-site VPN and have them work on the same subnet?

Again, the bridging issue. You could definitely do it with routers, but the ASA platform is pretty limited.

  • 1
  • 2
  • 3
  • 4
  • 5
  • Post
  • Reply